0
Under review

template has corrupt element

SeanB 6 years ago in By Screen / Design updated 6 years ago 2
Look at this screenshot. It shows the steps to add a narration condition - both on page load and on tap. In screen #2 I chose "1" > Tap to Set. My entire condition is then REMOVED FROM THE ELEMENT. What?

This element worked fine on the page the template was created from. Now in a new book, new page based on this template, it does this:

Answer

Answer
Under review
Hi Sean,
Thank you, this comment has alerted us that there's a problem with counters when they're used in templates. I think that in your case for the time being if you locate your counter element, it might have turned back into a text element. If you make it back into a counter and re-assign that element in any action sets or conditions where it's used, it should work again.

I hope this helps! I'll report the problem with counters.
Inna
Answer
Under review
Hi Sean,
Thank you, this comment has alerted us that there's a problem with counters when they're used in templates. I think that in your case for the time being if you locate your counter element, it might have turned back into a text element. If you make it back into a counter and re-assign that element in any action sets or conditions where it's used, it should work again.

I hope this helps! I'll report the problem with counters.
Inna
Yes I did find it was set to text, and listeners needed to be reset. What bugs me is the corruption in the screenshots. Notice in the last one the whole condition is lost. So I'm doing alot of rebuilding :/