0
Answered

Multiple language problems

Anita Sølver 6 years ago in By Screen / Publish • updated by Inna Komarovsky 5 years ago 4
I have tried setting up a small test app with multiple languages. I have used the video that shows how to do this: http://www.youtube.com/watch?v=ls7eZRDOCk4&feature...;

On the first page in the app, I have two language choices, set up as in the video. I have added a "jump to page" action after the language choice action (linked together).

I then have a cover with title in two languages (set to show if the language is chosen).

Last, I have the first page in the story, with two different text boxes, one for each language, set up the same way as the cover.

When I test under the "Interact" tab, everything works like a charm. I choose a language by clicking it, and it goes to the cover, and shows the correct language, and the same when I click ahead to the next page. I can also go back, and pick the other language, and everything still works as it's supposed to.

Then, when I share the app with myself, and try  it out on the iPad, something goes wrong:

If I go back to choose the other language, the app seems to insist on using the first chosen language. So if the user would happen to pick the wrong language first, they would be forced to shut down the app (and probably never use it again).

Is there a way to ensure, that it would work on the iPad, like it does under the Interact tab?

It is very possible that it's a mistake on my part. This is my first testrun with the builder :) Look forward to suggestions on how to move on.

Answer

Answer
Under review
Under the Page Properties do you have Refresh on Load set to No as shown in the image below?:
I have added a few more pages, to see if it was all the pages, or just specific pages that had this problem. It seems to only be the first page after language change. I have double checked the settings on the texts, and they're all fine. Have added two more texts to the same page, and the all show up in the same language at the same time, so that is consistent, but they don't show the right language, if the language is changed. But when I browse to the next pages, the language is right according to my choice(s).

Don't know if that helps to understand my problem :)
Answer
Under review
Under the Page Properties do you have Refresh on Load set to No as shown in the image below?:
Alin > Yes it was! I changed it to "Yes", and that solved the problem right away.
Brilliant. Thank you so much! :D