0
Under review

Trouble syncing with server

Stine Winther 5 years ago in By Screen / Interact updated by Inna Komarovsky 5 years ago 8
I'm having trouble syncing the app with interactplayer.

At first the only thing appearing in the app in interactplayer was one of my pictures (the first I tried adding in the builder). No background or anything.

I looked in the feedback and in the users guide, but couldn't seem to find any explanation.

I tried clearing browse data - that didn't help.

Now I have deleted the app from my player account, and then tried upload again - but now it won't sync at all.
When clicking "Interact" it starts syncing but then stops.
What can I do?

Regards, Stine

Answer

Answer
Under review
Hi Stine,

Was the app working earlier, or did this happen the first time you tried to preview this specific app?

It's possible that one of the files or action sets included could be causing a glitch. If you'd like, I could take a look at the app to try to find the problem. If you locate your app folder in Documents / InteractBuilder / [the name of the project group] / [the name of the app], and compress that folder to make a zip file, you can send it to me as an attachment, and I can test the app.

Otherwise, we could talk about the file types and action sets that are included in the app at this point.

Let me know which way you'd prefer : )
Inna Komarovsky
Answer
Under review
Hi Stine,

Was the app working earlier, or did this happen the first time you tried to preview this specific app?

It's possible that one of the files or action sets included could be causing a glitch. If you'd like, I could take a look at the app to try to find the problem. If you locate your app folder in Documents / InteractBuilder / [the name of the project group] / [the name of the app], and compress that folder to make a zip file, you can send it to me as an attachment, and I can test the app.

Otherwise, we could talk about the file types and action sets that are included in the app at this point.

Let me know which way you'd prefer : )
Inna Komarovsky
Hi Inna, thanks for your advice. You were right, I had to delete some files in the folder. Now it synced, BUT when interacterplayer opened and I tried logging in, I got this message:

Oops! You already have 5 devices registered to share apps

What is that about?? I haven't regesitered any devices. I have only logged in on my computer.

Stine



Ah ok, I just went into our system and corrected that information so that you can log in again.

(Sometimes InteractPlayer counts new browser windows as separate devices, so until we have a chance to fix this we are just making the adjustment manually if it comes up.)
Ok, thanks:) Now I synced one page, I got access and it looked fine. Then I tried syncing all the pages and all I get is a black screen...
And by the way, in danish we have some special letters. They look fine in the builder, but the player cannot read them?
And if I open and login to the interactplayer in the browser manually the app is not there.
And I can see that it counts my entries as devices, as you said...
The blank screen could mean that there's a problem with something on one of the other pages. It could be one of the action sets or the type of file used on that page.

At this point, the text elements in InteractBuilder are having trouble with accent marks in the text. We're planning to make accent marks available in one of the future updates, but I often actually recommend importing text as graphic elements because it gives you the most flexibility for text styling and font choices, and this would also allow you to use any special characters that you would need.

Do you have any file names that include accent marks? Not long ago, we noticed that this can cause errors.
Okay, I'll check the file names.
It's not the accent mark. In danish we have 3 different letters. Do I really have to make graphics with the text?! That's going to take a long time. Usually you work with text element visually on the background with lots of changes!

Another issue is, that the text elements does not appear in the right place in the interactplayer and the size is wrong.
Yes, unfortunately at this point we haven't yet gotten special characters to work, although it is definitely planned since we want InteractBuilder to be as customizable as possible for people around the world.

I can try to help you find an easy way to import the text as graphic elements. What program are you using for editing the images for your app? What font are you currently using?