0
Answered

video not playing at same time and in front of frame

Ann K AlteredEssence 7 years ago updated by Inna Komarovsky 7 years ago 1
Hi all,  I could use some help.  I have 3 videos on a page that should run as a button is tapped.  The tap triggers a cover graphic to fade out and to play the videos.  These videos are all on tap but instead only one runs unless the trigger is tapped 3 times. 
ALSO, when the video plays it jumps to the top layer on top of a graphic which is a frame.  The intent is to have a frame with the video playing within it not on top of it.

Answer

Answer
Answered
Hi Ann,
This seems to be a bug, but here's a workaround that can help you achieve the effect you're describing. The three videos are able to play at the same time if they are all chained after another action set. For example, you can start by hiding the button that makes the videos play.

Tap-Hide (Self)
behaviors chained after (all chained under one parent action set):
-PlayVideo (video 1)
-PlayVideo (video 2)
-PlayVideo (video 3)

I couldn't recreate the problem of having a video appear in front of a graphic element. Are you sure the border is layered to be in front of the video?
Answer
Answered
Hi Ann,
This seems to be a bug, but here's a workaround that can help you achieve the effect you're describing. The three videos are able to play at the same time if they are all chained after another action set. For example, you can start by hiding the button that makes the videos play.

Tap-Hide (Self)
behaviors chained after (all chained under one parent action set):
-PlayVideo (video 1)
-PlayVideo (video 2)
-PlayVideo (video 3)

I couldn't recreate the problem of having a video appear in front of a graphic element. Are you sure the border is layered to be in front of the video?
Hello Inna,
Changing the videos to all be chained under one parent worked, Thank you!
As for the layering, the videos are on layers 4,5 and 6 and the "cloud frame" is layer 16 but when the videos run the open and run on top of everything on the page.