0
Fixed

browser window remains opened after several web urls are loaded

Paul Snakes 7 years ago updated by Inna Komarovsky 6 years ago 4
Hi. I am finding a possible bug that somehow was already commented some time ago in a forum thread http://www.interactbuilder.com/forum/interactbuilder-3-0/browser-window-problem/; though the solution suggested there seems not to work: I create a Browser element where I want the web pages to show. I have two objets on screen with Browse behaviours added; both of them targetted to the same Browser Object. When I go into Interact mode, I load the first web page; I then load the second without closing the browser window (I let the show closing button option turned on), and It is succesfully loaded. But when I try to close the browser window, only the closing button dissapears, while the browser window itself remains open. It stays open also when I go into Design mode. I have to quit the app to have the b.window removed. Nevertheless, if I load a web page on the browser in InteractMode; and before tapping the second element with the browse behaviour I close the browser window; the latter reopens and closes normally. Do you know if this bug happens also in the published version? I am considering to create one different browser window per each browse behaviour to avoid that.. 

Answer

Answer
Fixed
Just adding an update that this problem is no longer happening in InteractBuilder 4.
Under review
We are trying to recreate this and we will let you know the results.
Started
We were able to recreate this problem and we are working on a fix. Thank you for pointing this out.
For the time being, try setting the browser element to be invisible on page load. This should prevent it from remaining visible when it is closed and when you leave Interact Mode.
Answer
Fixed
Just adding an update that this problem is no longer happening in InteractBuilder 4.