We want to hear your feedback! Submit your Questions, Ideas, Suggestions, and Problems.
0
Under review

This is an update to the problem with 3.4 freezing with database error

Judy K. Johnson 4 years ago in By Screen / Interact • updated by Alin Alexandru Matei (Support) 4 years ago 0
I downloaded the update you put out yesterday 1/25 to fix this problem with new Builder 3.4  

I am using Windows 7.1 to create the app.  The problem is with my Windows Player program. 

The two pages in my app that were affected now do play correctly in Player.  However, on one problem page, after it correctly plays in Player, it is impossible to turn the page forward or back.  Then Player can not be shut down so the only way to quit Player is with Task Manager.  The app freezes and must be shut down with Task Manager.

When I use my MacAir Player to view my app this does NOT happen.  I am able to page on past this page and complete the app.
Answer
Could you tell us what behaviors you have on that page?
0
Under review

shared app update please

cathy lane 4 years ago in By Screen / Interact • updated by Alin Alexandru Matei (Support) 4 years ago 0
I shared my app with Ezra over a week ago- I hope this was OK - no response so far. Should I send it to you guys at support? If so could I have your email.  I also sent a follow up email to Ezra outlining the problems with the shared app. Could you please update me your progress regarding the problems sharing the app as I am waiting to complete and publish my app.
Thank you
Cathy
Answer
Cathy, zip the app into a zip file and send it via email at alin@interactstudios.com. Also send the list of what problems you have. Thank you for your feedback.
0
Fixed

InteractPlayer | Animation Error

Pardesi Media 4 years ago in By Screen / Interact • updated 4 years ago 6
I am working on a very simple page, with an animation that is triggered by a Play button. When I run it on InteractPlayer.com, I see the attached screen "No image found error".



--
Adeel
Answer
Adeel, we just released build 4.0.6.  With this build you can rebuild and resync your app which will fix the animation issue you are having. 

To rebuild and resync your app follow these steps:
1. Go to the manage screen (the bookcase)
2. Simultaneously right click and hold your ALT key (or Option key if using a Mac).  You will see a menu come up and the last option is: "Rebuild and Resync".   Click this option.


0
Fixed

animation won't play on second tap

Charmaine Anderson 4 years ago in By Screen / Interact • updated by Inna Komarovsky (Administrator) 3 years ago 12
Animated graphic elements (.png sequences) set NOT to loop won't play in Interact mode on second tap.   I tried changing the replay from 0, to 1, to 100 and it still won't play again on second tap.  Kids will want to keep tapping things to make them happen again so it would be nice if we could resolve this.Thanks for looking into this or advising what I might be doing wrong.  
Answer
Could you make a sample app with the animations of those graphic elements? Thank you.
0
Answered

Draw Line

Jen Hoyte 4 years ago in By Screen / Interact • updated by Inna Komarovsky (Administrator) 4 years ago 3
In the old version, the DrawLine allowed you to start drawing, stop, start back drawing in a different direction, stop, continue in a different direction and so on.  In this way you could get a bent line.
Now once the mouse is released, the line cannot be continued in any direction.
How can I get it to work like before?
Thanks.
Answer
Hi Jen,
If you add a Drag-Move (Self) action set to the element, the effect should work as it did before, where you can continue adding to the line.

0
Fixed

Android player issues

Ranco 4 years ago in By Screen / Interact • updated by Inna Komarovsky (Administrator) 4 years ago 2
Tried the InteractPlayer on my brand new Samsung Galaxy S4.
First, as already mentioned, it is hard to see the login window, but it's only once.
Second, it takes 25 seconds to start (!), the screen is black (no splash), as if it is off. Very frustrating. And not only in the first run. Same with my S3 mini.
Third, when I download an app, I get an error message:

I can't click the "Send Error" (and can't hardly see it). Download continues and completes, but there's nothing in any of the shelves.
And forth - the icon for the player is SO similar to Google Play icon:


Please advise...
Ranco
Answer
We were able to recreate most of the errors that you've encounter and we are working on a fix. Thank you for letting us know about them.
0
Fixed

Audio bug - on tap to play audio causes animation to be sliced

Charmaine Anderson 5 years ago in By Screen / Interact • updated by Ezra Weinstein (Administrator) 5 years ago 1

After assigning on tap to animated .png sequence to play an short .mp3 sound effect, a small rectangular piece of the animation displays in the center of the screen when element is tapped.  The animation continues to its target location but the rectangle with a slice of the animation stays in place.  I'm using a PC with the latest version of IB3.  Then program crashed and keeps crashing when I reopen the program.  Hopefully this will resolve when I reboot... spent the entire day try to work around IB3 bugs....sigh.

Answer

This issue seems to happen only on Windows and not on a Mac.  It should not appear when you run your app on a device, we are trying to find out what the issue is and get it resolved.

0
Fixed

No Image for Animation character

Ted Ollikkala 4 years ago in By Screen / Interact • updated by Ezra Weinstein (Administrator) 4 years ago 12
When I try to view the animation of a character (I've tried 10 frames, 3 frames with completely different images) I always get a green box with a single diagonal line across it instead of the character that I'm trying to animate after it loads in the player. The ones I created on the previous build of InteractBuilder still play fine (they are have not been run through the new build. (I updated earlier today, though) - What does the box with the green strikethrough mean?
Answer
Well, it took closer to 30 hours, but nonetheless the issue has now been fixed with the latest release 4.0.3.
0
Under review

deleting apps in the player

Melissa Lind 4 years ago in By Screen / Interact • updated by Alin Alexandru Matei (Support) 4 years ago 0
I still have a couple of apps that won't delete in my list of "My Apps". They are around 8 months old. Not a big problem obviously, but I thought you'd want to know.

Here is the error info:

InteractBuilder Version: 3.4 Build 350
Device: MacBook Pro
Processor: Intel Core i5
Memory: 4 GB
System: 10.6.8

--------------------
An error occurred while accessing the database.

An error occurred while accessing the database.

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's Umbrella.zip' AND ConsumerMember_Id=100079' at line 1

graphic id 10086247 of group id 10086221 of group id 10086219 of card id 147088 of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer",mouseUp,36
card id 147088 of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer",DeleteDownloadApp,928,button id 1014 of group id 1010 of card id 1002 of stack "Behaviors" of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer"
stack "libApp" of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer",DeleteMyApp,7128
stack "libApp" of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer",ibRDS,7069
stack "libApp" of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer",CheckDBErr,6649
stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer",DoError,15410,button id 1004 of card id 1002 of stack "Behaviors" of stack "/Users/melissahlind/Desktop/InteractPlayer.app/Contents/MacOS/InteractPlayer"
Answer
What version and build of InteractPlayer are you using? I tried to recreate this situation but the app got deleted when I clicked the Delete button.
0
Not a bug

ToggleAudio

Ranco 5 years ago in By Screen / Interact • updated by Ezra Weinstein (Administrator) 5 years ago 7

ToggleAudio  doesn't work, unless I use it incorrectly:

I have a little microphone button in every page, which when clicked hides itself and shows a mic with cross ("no audio"). This one does the same. Both buttons initiate "ToggleAudio" behavior. But that doesn't do the trick.

Ranco

Answer

I've attached a small app with how the ToggleAudio behavior works. On first page I have two elements both with toggle audio behavior, and on the second page I have a text element with a PlayAudio on Page Load.

204 - ToggleAudio.zip